Skymaster Forum  

Go Back   Skymaster Forum > Messages
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-06-20, 12:17 PM
mshac's Avatar
mshac mshac is offline
Registered User
 
Join Date: Aug 2020
Location: North Texas
Posts: 156
mshac is on a distinguished road
Strange engine oil level readings

Drained all the oil out of the rear engine and changed the filter. Before draining, rear oil level read near 8 qts. Let oil drain overnight, so hopefully got every drop out I could.

I added 6.5 qts based on advice I've seen here, and experienced with other motors. Started the engine, got good oil pressure readings, it ran smooth, so I shut it down.

I checked the dipstick, and the oil was showing near 4 qts. I thought it would come up in few moments so I checked it again later, but still barely over 4 qts!

No oil has leaked out. In fact I cleaned the engine after the oil change. Its spotless. Why do I read 4 qts when I put in 6.5 qts???

Logic would say its the wrong dipstick, with incorrect markings. If that's true, then the 8 qt marking would be more like 10.5 qts - no wonder it was blowing out oil!

I caught all the old oil in a jerry can, so I could measure it if needed.

My next step is to verify the PN on the dipstick, but have any of you ever experienced anything similar?
Reply With Quote
 


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:48 AM.


Powered by vBulletin® Version 3.6.9
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.